1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Amiko a3 help

Discussion in 'General Satellite Discussion' started by jonnymac67, Oct 8, 2017.

  1. jonnymac67

    jonnymac67 Member

    Help I have been trying to fix a mate's amiko a3 the box seems to be stuck on the boot screen, does anyone have a recovery file that I can try to get it up and running again ta..
     
  2. bazcfc1

    bazcfc1 TK Veteran

  3. dappa2

    dappa2 Member

    best reflash it or look up on google for the low level recovery tool for amiko a3, if its on 2.0.78 I'd remove that as that firmware causes the most problems with that box from my experience.
     
  4. jonnymac67

    jonnymac67 Member

    Hi
    Thanks for the responses
    Thanks for the website think I can use stuff on this, also as it's not my box I don't know what firmware it has in it, hopefully I can suss it out ta
     
  5. gravehead

    gravehead Member

    Try the website -
    amikoreceiver.com
     
  6. marcus-g

    marcus-g Member Forum Supporter

  7. jonnymac67

    jonnymac67 Member

    Thanks mate your a star
     
  8. smudgester

    smudgester Member

    Thanks for that.

    Will try it out as I have the same problem as the OP on both my A3 boxes.

    Sometimes they boot fine , sometimes they keep coming up with 'android .... has stopped responding', etc.

    Would be good to get them back working (even with just Freesat channels)
     
  9. dappa2

    dappa2 Member

    Find out what firmware your boxes are running, if they are on 2.0.78 remove that firmware off the boxes as that is the problem, downgrade to 2.0.72 as that is the last known really stable version.

    My amiko a3 I dont use it no more but once I removed that firmware off and downgraded it, all the booting problems stopped and you will notice they are slightly faster too.

    Another thing I'd recommend is you remove the setting for quick standby to off regardless of what firmware your on as that can cause some screen issues when you quickly turn the box on, deep standby overall is best for least buggy experience.

    Amiko a3s are buggy as hell but if you do what I have said will minimise it greatly.

    Another tip, if you ever use the built in browser always delete the cache after as it bogs the box down.
     
  10. smudgester

    smudgester Member

    Any idea where I can get the earlier firmware from?
     
  11. smudgester

    smudgester Member

  12. smudgester

    smudgester Member

    Never mind - all sorted ( hopefully )

    Just got to track down an up to date picon collection
     
  13. dappa2

    dappa2 Member

    look on xbmc wizard site, they usually have picons on there for a3s
     
  14. jonnymac67

    jonnymac67 Member

    All I see on his website now is amiko CCTV ?, Have got it working again but glad it's not my box as it would have been in the bin ages ago, vu+ for me anytime, thanks for people's help..
     
  15. marcus-g

    marcus-g Member Forum Supporter

    Use the picon downloader on the box. xbmcwizard picons are wrongly sized and crash the A3
     

Share This Page