1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issues with hdd setup

Discussion in 'General Satellite Discussion' started by Ezios_15, Mar 20, 2017.

  1. Ezios_15

    Ezios_15 Member

    Hi guys before making this thread read loads of others and tried but just does not work so any help would be really appreciated. Tried using 8gb usb i have to run epg and timeshift plus small recordings but usb wouldnt record past 4gb and playback quality was rubbish glitching and jumping rubbish usb i think plus i have wifi at back and i dont want front door left open so Then i realised i had a spare 32gb sandisk ultra micro sd so i put that in initialised it mounted as hdd it records perfect and plays back perfect but time shift wont work i get all different messages popping up like unable to create hardlink and no hard disk found /hdd/movie is not ext of ext2 plus i had cant going to live tv switch to live tv. Then i put usb back in and get all same errors with that. When i try to make swap file it says no device detected or something also what is swapfile ? And now since trying to switch to cross epg to hdd ive got loads of epg missing but before using any memory stick/ cards i have full epg off flash memory. Any ideas or help please stressing me out for hours lol can you turn back usb into 2 and put usb and wifi in back ? Cheers
     
    wivz64 likes this.
  2. Tezzers

    Tezzers Member

    Did you format the usb`s to fat32 before using them ? if not, that`s what you need to try next :)
     
  3. Ezios_15

    Ezios_15 Member

    Hi buddy yes i did just no bloody good lol the usb was working perfect when i first used it in front apart from wouldnt record more than 4gb. Then since i tried using sd which records perfect time shift and epg is all messed up and cant seem to fix it
     
  4. Ezios_15

    Ezios_15 Member

    Was hoping for some replies lol anyway just been and purchased a high quality sandisk usb 3.0 32g usb format it to fat32 then initialised it then created and activated swap file mounted usb as hdd put time shift location to hdd/timeshift then setup cross epg to hdd and downloaded. So now got my epg working i can pause rewind ect and record programs all play back perfect however now i just get error every time i change channel saying creating hard link to timeshift file failed. I dont get it my timeshift is working perfect ? Any ideas guys thats my only problem now just that error message i mean i can use it and ignore it as it is but just annoying i like to fix things lol
     
    wivz64 likes this.
  5. silverblack

    silverblack Member

    What box and image ?
     
  6. Ezios_15

    Ezios_15 Member

    Hi zgemma h2h how do i check what image ? I know its openatv
     
  7. silverblack

    silverblack Member

  8. Ezios_15

    Ezios_15 Member

    That link just mentions about it auto recording but ill try messing with that, but the error says basically that the file type is not supported on usb although it is working i can pause rewind ect thx for helping
     
  9. silverblack

    silverblack Member

    Just thought the reason for the error was running out of HDD space,might be wrong tho.
     
  10. Tezzers

    Tezzers Member

    This might sound daft, but did you reboot after setting up your new drive ? Also you can find which image by Menu > Info > About :)
     
  11. Willo3092

    Willo3092 TK Veteran Forum Supporter

    Go to Menu > Info Panel > Plugins > Mount Manager and make sure your drive is mounted as /media/hdd and is ext4 R/W

    On ViX it's Menu > Setup > ViX > Mount Manager
     
  12. Ezios_15

    Ezios_15 Member

    Yes i definately rebooted and my image is openatv version 5.3 v5.202 by kidda that what info i see down page is this up to date ? Cheers
     
  13. Ezios_15

    Ezios_15 Member

    Just looked it is buddy the error i get says it needs to be ext 2 or ext 3 maybe thats the issue or is it meant to be ext 4 ?
     
  14. Tezzers

    Tezzers Member

    I`m not sure what image that is TBH, but someone will know
     
  15. Tezzers

    Tezzers Member

    Don`t want to cause confusion, but mine is set at ext 3 from the flash and it works fine
    EDIT: when i say from the flash, i mean when i first flashed and set up, i use ipab and that is what it says to set it to, ext 3 :)
     
  16. Ezios_15

    Ezios_15 Member

    The exact error message is. Creating hardlink to timeshift file failed. The file system on your time shift device does not support hardlinks. Make sure it is formatted in ext2 or ext3. So basically i think this means only way it will work is if the hdd is ext 2 or 3 am i right if so why does the box make it ext4 and wouldnt everyone have same issue ?
     
  17. Ezios_15

    Ezios_15 Member

    Thought so how do i get it to ext 3 though lol and if i set it to ext 3 with a program on pc when i initialise it again it will go back to ext4 because thats what box initialises it to
     
  18. Tezzers

    Tezzers Member

    Just follow willo`s advice above for remounting, do it through your box, no need to get a PC involved lol Post 11
     
  19. Tezzers

    Tezzers Member

    Be sure to save setting afterwards, it`s green on mine
     
  20. Ezios_15

    Ezios_15 Member

    My usb is already mounted as media/hdd and in ext4 rw but you just said yours is mounted as ext3 ? And my error message says it needs to be ext 2 or 3
     

Share This Page