1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hi Guest, If you haven't already please like our Facebook Page. We post Discount Codes for the Major online retailers. We saved members a fortune over Xmas and continue to post amazing discounts for everyday items. You need to add us to see what i'm taking about. CLICK HERE - click LIKE, add us to "SEE FIRST". So you don't miss expiring codes.

Picture Pixelating every 1 Minute for few seconds tried everything.

Discussion in 'General Cable TV.' started by Tim Beech, Nov 8, 2018.

  1. Tim Beech

    Tim Beech Registered

    25
    1
    3
    Male
    Hi Am on Cable Vermin and use a 12500 MHZ Splitter and, recently am having issue's with the picture pixelating every 30-45 Seconds on every Channel, My signal is good it's 73%.
    Strange because it was happening a few year's ago with another Splitter, the Channels were freezing, so that's why i bought a new one and this one i have now I haven't had a problem with until now. It's definitely not my Internet Connection as i get 100 Mp Download speed, and about 7 Upload, I've ran a few Speed Tests.,I have also tried changing coax (Proper) wires around, Swapping Ethernet Cables/Hdmi Wires etc.

    Any Help would be very appreciated as this Issue is slightly Irritating!
     
  2. cactikid

    cactikid VIP Member

    16,318
    1,100
    133
    Correct splitter vm use is 5-1000mhz.
     
  3. Tim Beech

    Tim Beech Registered

    25
    1
    3
    Male
    never had a problem with this splitter until now though
     
  4. cactikid

    cactikid VIP Member

    16,318
    1,100
    133
    Proper cable and connections are vital as if not shielded can have interference issues,also worth checking of any local issues posted + rebooting box and router can clear bugs.
     
  5. pabloescaban

    pabloescaban TK Veteran Forum Supporter

    4,933
    2,136
    133
    Male
    {builder
    if you are using a no-name splitter, swap it for a Labgear from Screwfix and the problem will be solved
    The best ones are Tratec or Technetix but these are only available online whereas Screwfix are open 7 days a week
    This is assuming you are using proper shielded cables as mentioned above by @cactikid
     
  6. Tim Beech

    Tim Beech Registered

    25
    1
    3
    Male
    I am using a Technetix Splitter and it's screwed on the wall tight! should i try rebooting the box am using ipab Build, the cables are shielded really thick and aren't the cheap coax cables
     
  7. ianw314

    ianw314 TK Veteran Forum Supporter

    611
    198
    83
    Male
    {Finance
    Singapore
    Ipab isn't supporting their builds anymore I believe, so first of all before buying any new cables/splitters etc have a look in here http://www.techkings.org/resources/ and flash a new build on you're receiver woosh/grog or willo builds are available that you might want to choose?
     
  8. Tim Beech

    Tim Beech Registered

    25
    1
    3
    Male
    I'll reflash too a new build thanks
     
  9. Jazzie_bee

    Jazzie_bee Registered

    269
    40
    28
    is it freezing on FTA channels?