1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

skybox F5 psu rating

Discussion in 'Skybox F3 - F5 - F6' started by steptoe, Jul 15, 2017 at 3:39 PM.

  1. steptoe

    steptoe Member

    can someone tell me the power rating of the psu for a skybox F5please.?
    I'm a numpty,
    I've been re-arranging all my cables and have mixed up which psu plugs into what, and 3 of them have the same size jacks,
    :oops:
    :mad:
     
    mike142 likes this.
  2. mike142

    mike142 Member

    This is from a "Genuine" one on Amazon
    • Genuine Power Supply Adapter For Skybox, Openbox, Libertview F5s, V5s, F3, F3s, F6, M3, PSU
    • Input : 100-240v ac 50/60Hz
    • Output: DC 12V - 2.0A
    or you could look on ebay & see if you can find one that looks the same.
    https://www.ebay.co.uk/sch/i.html?_from=R40&_sacat=0&_oac=1&_nkw=skybox+f5+power+supply&_sop=12
     
    chrisrcromwe and steptoe like this.
  3. steptoe

    steptoe Member

    chrisrcromwe likes this.
  4. steptoe

    steptoe Member

    mmm, well, to follow this up,
    none of my PSU's are 2amp,
    2 x 1amp, and one @ 0.5amp,,,,,,,,, ??????
    I wonder if this is why occassionally my box freezes/locks up,,,,,,, ?
    must have a search through my box of psu's and see if I have a 2amp one somewhere.
     
  5. mike142

    mike142 Member

    By what I've read the 2 amp replaces lower rated power adapters with the same voltage such as 1.5a , 1a, 0.5a etc.
    My V8s is I.5amp, so you probably have the original one in among those three.
     
    Last edited: Jul 16, 2017 at 10:12 PM
  6. steptoe

    steptoe Member

    thanks @mike142
    I dont usually turn my box off, just put it in standby,
    when I then turn it on I have to leave it on the current channel for about a minute,
    if I try and scroll through the channels or epg too soon the box locks up, and needs a hard poweroff to work again.
    otherwise no problems,
    maybe its just on the way out, I've had it since the eurovox stopped working, so a few years now, ,,,,,
     
    mike142 likes this.
  7. the reaper

    the reaper VIP Member Forum Supporter

    The official psu is rated 12V @ 2amp
    Reaper.
     
    steptoe and chrisrcromwe like this.
  8. steptoe

    steptoe Member

    Something I've just realised,
    Its only been like this since I flashed it a short while ago,
    or is that simply coincidence?
    I think I'll get a new 2a PSU in any case anyway, they're fairly inexpensive.
     
  9. the reaper

    the reaper VIP Member Forum Supporter

    Most probably a coincidence if you flashed with correct firmware.
    Reaper.
     
    chrisrcromwe and steptoe like this.

Share This Page