1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

time shift error

Discussion in 'Zgemma-Star H5.2S' started by help36, Jun 19, 2017 at 10:07 AM.

  1. help36

    help36 Member

    Morning all,

    Hope everyone enjoyed the sun at the weekend.

    I have a problem with my zgemma H5.2, using wooshbuild and have basically been messing (sorry i didn't mean to) and now have an error about my timeshift.

    Basically i went into EPG-recordig- bookmarks- my USB stick and then had a load of things show up in my planner and started deleting things i did this as it said i had no memory and was hoping to make some more available.

    So i don't know why i had no memory only using a 32gb usb stick but it was fine when i started.

    So i have the following error:
    the directory /media/timeshift/ is not a EXT2, EXT3, EXT4, NFS or CIFS partition. make sure you select a valid partition type.

    Is there an easy way to fix this please?

    Also there are still some files showing in my program planner so i could delete again by mistake can i hide these so it will just show any recorded channels?

    thanks for your help
     
  2. andybhoy1984

    andybhoy1984 Forum Supporter

    Re do your usb drive

    Initialise your usb/hdd

    Plug in your usb/hdd device that you are going to be using as your
    storage media into the rear of your box.

    Menu... setup... System... Storage Devices... Initialisation



    Creating a USB swap file (virtual memory)


    Menu... Info Panel... Plugins... SwapManager...

    Create (green button) this takes a few minutes
    256mb (can be bigger if you have a larger device)
    Activate (red button)
    Autostart (yellow button)
    Exit


    Correct Set Up HDD/USB

    Menu
    Setup
    System
    Epg
    Settings
    Epg location.............../media/hdd.

    Menu
    Setup
    Crossepg
    Configure
    Storage device............"ur usb"

    Menu
    Setup
    System
    Recording and playback settings
    Default movie location......./media/hdd/movie/

    Menu
    Setup
    System
    Timeshift settings
    timeshift location............../media/hdd/timeshift
    auto start timeshift after........ (i use 1 min)
     
  3. help36

    help36 Member

    i have previously setup the USB and had it running fine but now it doesn't appear to work because of my "messing".

    i deleted my USB and tired to plug it in as a new device and initialise it this morning before work, but it still recognised so didn't treat it like new. i was hoping this would sort it out.
     
  4. help36

    help36 Member

    Home from work now and trying to sort this out.

    When I turn the box on, change channel do anything I get the following error message;

    Error
    Creating hardlink to timeshift file failed!
    The filesystem on your timeshift-device does not support hardlinks.
    Make sure it is formatted in EXT2,EXT3 or EXT4!
    [Errno 1] operation not permitted.

    When I try and initialise the USB it says:

    Error
    Initialising storage device .... Error: Umount: can't unmounts /media/hdd: Device or resource busy

    I had the USB working fine but as I said since I deleted something in program planner bookmarks its broken!

    can anyone help please?
     
  5. andybhoy1984

    andybhoy1984 Forum Supporter

    Have you went in and manually unmounted the drive then try again ?
     
  6. ste

    ste Forum Supporter

    Get it on the menu ready. unplug the usb then plug back in and do it straight away - should work now.
     
  7. help36

    help36 Member

    don't know how to manually unmount the drive?

    Ste I tried to unplug and plug back in but that doesn't appear to have worked?
     
  8. help36

    help36 Member

    Ste when I tried it your way it said,

    Error
    Initialising storage device ...
    Error: Timeout elapsed, sorry
     
  9. help36

    help36 Member

    Now when I go setup system etc. storage device is not in the menu?
     
  10. ste

    ste Forum Supporter

    You need to get it on the storage devices menu, stick the usb drive in and click on initialisation straight away and hit go - never failed me.
     
  11. help36

    help36 Member

    I have now initialised the USB but cant pause. When I go into menu - timeshift and try to save the settings it says.

    error

    The directory /media/hdd/timeshift/ is not a EXT2, EXT3, EXT4, NFS or CIFS partition.
    Make sure you select a valid partition type.

    If I reflash the box would I still have the same problem? I would have to do it from scratch but if it works it would be better than this.
     
  12. help36

    help36 Member

    Don't know what I have or haven't done but it appears to be working for now, I'm touching nothing!!!

    Hopefully wont have any more problems, thanks for your help again ste
     
  13. ste

    ste Forum Supporter

    Haha nice one :)

    They can be funny with USB drives.

    I had to change the one in my friends box yesterday because it just decided to no longer want to read it.
     

Share This Page