1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Has sky blocked mobdro?

Discussion in 'IPTV Guides Support and Discussions' started by Adamski84, Mar 18, 2017.

  1. Adamski84

    Adamski84 Member

    Hi guys, I've been searching on forum and can't seem to find another post about this specifically. So I've been using mobdro on my android device for some time now and today in the house I went to use it. Low and behold it won't work when I'm connected to my wifi (sky). Still working on my 4g though so I am assuming sky have recently blocked this. Any ideas, if any, how to get round this. Any help would be much appreciated.
     
  2. ianw314

    ianw314 Forum Supporter

    Have it on my firestick working ok using vm but like you say maybe sky have blocked it similar with blocking plex on nowtv boxes?
     
  3. Adamski84

    Adamski84 Member

    Do you know of anyway to alter the security
     
  4. ianw314

    ianw314 Forum Supporter

    Sorry pal a don't but if it can be done someone will be along shortly to let you know how it can be ;)
     
  5. Adamski84

    Adamski84 Member

    Hopefully. None of my channels working either
     
  6. danlou

    danlou Member

    if you turn off your WiFi it may work but remember you're eating into your data allowance. Not a problem if you're with unlimited data of course...
     
  7. rmcope

    rmcope Member

    Any further news on this potential block as experience same issue
     
  8. tel1704

    tel1704 Member

    I am on Sky and the same has happened ,when the football finished Mobdro was working again,I managed to get most of the 1st half this morning for UTD game then it went off again,I installed a free vpn which got it working but made it too slow to watch,maybe a paid vpn is the answer.
     
  9. Having the same problems now. My channels wont work on my star 2s box and i have no idea what to do
     
  10. yellowking

    yellowking Member

    Cs is not blocked but if you mean Iptv then the suppliers are constantly being blocked by UK Isp's.

    The govt are at war with us in this area.

    Sent from my SM-G935F using Tapatalk
     
  11. mrtweaks

    mrtweaks Member

    Try changing the dns on the wifi to google 8.8.8.8 or try a smart dns it has worked for me. That way you are not using their DNS to access site.
     
    danlou likes this.
  12. Jason1988

    Jason1988 Member

    I downloaded a VPN and it has seemed to work
     
    jonty likes this.
  13. jiro

    jiro Member

    have you tried turning of youre sky broadband shield off
     
  14. Jason1988

    Jason1988 Member

    Yes tried it and all
     
  15. John Cummings

    John Cummings Member

    Download turbo vpn from Google play it's free and it works.
     
  16. DeanR1977

    DeanR1977 Member

    Just tested mine & it's working fine. Maybe you need to update your app or turn Shield off. Or maybe when a main game is on it maybe a different story?
     

Share This Page